Does my soundcard exist?

From: Les Klassen Hamm <leskh_at_no.spam.please>
Date: Mon Feb 08 1999 - 14:09:46 CST

Hi all,

I have been unable to get sound to work under linux. I've followed the Sound
HOW-TO's, but I'm lost. Even the most basic tests (ie cat /dev/sndstat) return
errors, for instance:
        cat: /dev/sndstat: Operation not supported by device

The sound card is a PCI card with an S3 chipset (sonic vibes), which the kernel
config even asks questions about, so linux is not oblivious to the type of
card. So I tried Fore-Front's $20 drivers, and they correctly found and named
the card chipset, said all was well, but the most basic still leaves me with
"Operation not supported by device" replies. And yes, I read the OSS info and
tried the drivers without native linux sound support compiled in or in modules.

Win95 on the same computer runs all peripherals well, so I don't suspect IRQ
troubles. So I wondered if linux was even finding the sound card. Here I get
two DIFFERENT messages. If I cat /proc/pci I get this (relevant portions
    Bus 0, device 20, function 0:
     Multimedia audio controller: S3 Inc. SonicVibes (rev 0).
      Medium devsel. IRQ 11. Master Capable. Latency=32.
      I/O at 0x80000000 [0x80000001].
      I/O at 0xfffffff0 [0xfffffff1].
      I/O at 0x5800 [0x5801].
      I/O at 0x5804 [0x5805].
      I/O at 0xfffffff8 [0xfffffff9].
which seems to indicate that it knows about the card and what it is, and the
IRQ is appropriate.
If I run /usr/X11R6/bin/scanpci I get the following (I left all of it in in
case it's relevant). Note particularly the last line:

        PCI says configuration type 1

        PCI probing configuration type 1
        Probing for devices on PCI bus 0:

        pci bus 0x0 cardnum 0x00 function 0x0000: vendor 0x8086 device 0x1250
                 Intel 82439

        pci bus 0x0 cardnum 0x07 function 0x0000: vendor 0x8086 device 0x7000
                 Intel 82371 pci-isa bridge

        pci bus 0x0 cardnum 0x07 function 0x0001: vendor 0x8086 device 0x7010
                 Intel 82371 bus-master IDE controller

        pci bus 0x0 cardnum 0x11 function 0x0000: vendor 0x5333 device 0x8a01
                 S3 ViRGE/DX or /GX

        pci bus 0x0 cardnum 0x14 function 0x0000: vendor 0x5333 device 0xca00
                 S3 Device unknown

Is my problem here somewhere? Is linux not finding or recognizing the card? Can
I force it to or feed it info somehow? Or am I barking up the wrong tree?

Redhat: 5.2
Kernel: 2.2.1

Many thanks for ANY help you can offer.

Saskatoon Linux Group Mailing List.
To unsubscribe, send mail to
'' with
'unsubscribe' in the body.
Received on Mon Feb 8 14:09:46 1999

This archive was generated by hypermail 2.1.8 : Sun Jan 09 2005 - 13:53:58 CST